ubuntu 内核升级到Linux 4.4.0-121-generic x86_64 后安装docker到18.03.0-ce

安装基本按照官方文档:
https://docs.docker.com/install/linux/docker-ce/ubuntu/

但是如果有些问题不顺利可能会重装,删除旧的docker 要注意的地方:

rm -rf /var/lib/docker/

如果改过bridge的名字,注意这个地方/etc/docker/daemon.json:

{
  "bridge": "docker0"
}

如果docker 起不来,检查
/etc/systemd/system/docker.service.d 下的脚本,可以删除。

apt install docker-ce 的时候有可能会遇到 libseccomp2 版本的问题
下载要求的版本进行安装即可

dpkg -i libseccomp2_2.3.1-2.1ubuntu2_16.04.1_amd64.deb

最终实现:

# uname -msr
Linux 4.4.0-121-generic x86_64
# docker version
Client:
 Version:       18.03.0-ce
 API version:   1.37
 Go version:    go1.9.4
 Git commit:    0520e24
 Built: Wed Mar 21 23:10:01 2018
 OS/Arch:       linux/amd64
 Experimental:  false
 Orchestrator:  swarm

Server:
 Engine:
  Version:      18.03.0-ce
  API version:  1.37 (minimum version 1.12)
  Go version:   go1.9.4
  Git commit:   0520e24
  Built:        Wed Mar 21 23:08:31 2018
  OS/Arch:      linux/amd64
  Experimental: false

互联网广告,网络营销,数字营销,手游推广,手机流量,国外网络广告和营销,网络推广,国外电子商务营销,国外广告联盟发布,搜索引擎优化,英文站建设,域名投资,域名停放,谷歌广告,adsense,adwords,Amazon推广,Clickbank,Yeahmobi,MobVista,Avazu