RHSA-2020:3916: curl 安全更新漏洞修复

阿里云报警漏洞,是个curl相关的低版本漏洞,详情如下:
影响说明
软件:
curl 7.29.0-57.el7
命中:
curl version less than 0:7.29.0-59.el7
路径:
/usr/bin/curl
软件:
libcurl 7.29.0-57.el7
命中:
libcurl version less than 0:7.29.0-59.el7
路径:
/usr/lib64/libcurl.so.4

RHSA-2020:3916: curl 安全更新漏洞修复

升级方法如下:
1、查看本地版本,yum list curl,显示可用版本为7.29.0-59.el7_9.1

RHSA-2020:3916: curl 安全更新漏洞修复
RHSA-2020:3916: curl 安全更新漏洞修复

2、执行 yum update curl 进行升级,相关的依赖就是libcurl ,也一同升级,选择y

RHSA-2020:3916: curl 安全更新漏洞修复
RHSA-2020:3916: curl 安全更新漏洞修复

3、再次查看yum list curl ,发现已经升级到最新版本。最好重启下服务器。

RHSA-2020:3916: curl 安全更新漏洞修复
RHSA-2020:3916: curl 安全更新漏洞修复

4、 如果安装了开发相关依赖库,要升级:yum update libcurl-devel

京ICP备11047313号-19 术语 百科 技巧 彩虹岛电子书