centos7下编译安装nginx时configure报错需要安装的包

一般下载tar.gz后,需要安装很多个包,总之一言难尽,才会configure顺利:

   30  yum -y install gcc-c++
   31  yum install -y pcre pcre-devel
   32  yum install -y zlib zlib-devel
   33  yum install -y openssl openssl-devel
    3  yum -y install nginx
   16  yum -y install git
   34  yum  systemd -y
   35  yum install  systemd -y
   47  yum -y install mlocate
   80  yum -y install gcc-c++
   81  yum install -y pcre pcre-devel
   82  yum install -y zlib zlib-devel
   83  yum install -y openssl openssl-devel
  111  yum -y install nginx
  121  yum -y install gcc gcc-c++ make libtool zlib zlib-devel openssl openssl-devel pcre pcre-devel
  144  yum groupinstall 'Development Tools'
  146  yum install gcc gcc-c++ pcre-devel zlib-devel make unzip openssl-devel
  147  yum -y install XSLT
  148  yum -y install libxml2 libxml2-dev
  149  yum -y install libxslt-devel
  150  yum -y install gd-devel
  152  yum -y install gd-devel
  153  yum -y install GeoIP GeoIP-devel GeoIP-data
  155  yum -y install perl-devel perl-ExtUtils-Embed
  157  yum -y install GeoIP GeoIP-devel GeoIP-data
  158  yum install gperftools

接下来configure,然后make和make install 就可以了。

京ICP备11047313号-19 彩虹岛电子书